Join for Free  |  Login

Back

ProSelect on Mac OSX 10.15 Catalina & newer

Last Updated May 28, 2021

Apple released OSX Catalina (OSX 10.15) in October 2019 and Big Sur (OSX 11) in October 2020 and all new Macs come with one of these versions pre-installed.

Starting with OSX Catalina, Apple introduced a number of major changes to the way applications work on OSX.  The major ones that affect ProSelect users are:

1. 32-bit applications are no longer permitted

All applications run on Catalina or newer must now be 64-bit so you need ProSelect 2019r2 or newer to run on Catalina or Big Sur without issues. This MacWorld website page explains how you can find out which of your currently installed applications will or will not work on Catalina.

2. Enhanced Security Requirements

Starting with OSX 10.14 (Mojave), OSX started asking your permission when an application needed to access certain system resources such as System Events, the Finder and other applications (such as connecting to Photoshop during High-Res Production, opening original images files in Photoshop or running custom effects actions).

Catalina and newer version of OSX extend this even further as you now have to give permission for applications to access your Desktop and Documents folder and other areas of your disk. Also, some areas of your disk that were previously available for applications to saved temporary data files are no longer accessible and the applications must be updated to use alternative areas.

See the section below "Resolving Issues" for workarounds, solutions, and other currently known issues.

If you have purchased a new computer using an Apple M1 processor then also see this article: ProSelect on OSX 11 (Big Sur) 

Running ProSelect on Catalina or newer - "Must Do" List

  1. Download and Install ProSelect 2019r2 or later (see next section).
  2. Enable Full Disk Access - See item 1 in the section below
  3. Enable Access to System Events and Connection to Photoshop - See item 3 in the section below

Which version of ProSelect do I need?

If you are licensed to use ProSelect 2019r2 or newer then best to download the latest version for your license. Currently, this would be either ProSelect 2019r2.12 on the Old Versions Downloads page  or ProSelect 2020r1.7 on the Latest Releases download page.

If your ProSelect license is for versions of ProSelect prior to 2019r2 and you want to (or need to) be using OSX Catalina or newer on your computer then TimeExposure offers a range of discounted upgrade and payment options for you. You will find these on the Upgrades page in our Store. Important: Make sure that you are logged in to TimeExposure.com using the same email address that your current ProSelect software is registered to.

Resolving Issues

1. Enable "Full Disk Access" for ProSelect

To allow ProSelect to connect to Photoshop, run Production and save files wherever you choose:

  1. Open your System Preferences (under Apple Menu) -> Security & Privacy -> Privacy Tab. If you have ProSelect 2020r1.5 or newer, you can use the shortcut "Enable Full Disk Access" at the bottom of the Help Menu in ProSelect.

  2. Click the lock icon in the bottom left corner of this window and enter your login password to allow you to make changes.

  3. Select Full Disk Access in the list on the left-hand side.

  4. Look for ProSelect.app in the list on the right-hand side and check the box next to the ProSelect.app. If ProSelect does not appear in the list, click the + button below the right-hand list, navigate to your Applications folder, open the ProSelect folder then select ProSelect.app. This will add it to the list and allow you to check the checkbox.

  5. Make sure that you also do this for the version of Photoshop that you are using.

 

  

2. Allow Connection to Photoshop

You need to give ProSelect permission to open files in Photoshop or to send commands to Photoshop. 

Generally, OSX will ask you for permission the first time you attempt one of these actions.  If you did not allow this or if you are having issues with accessing these areas, check the System Preferences (under Apple Menu) -> Security & Privacy -> Privacy Tab -> Automation.

 

Note: To make any changes in this area, you need to click the lock icon in the bottom left corner of this window and enter your login password. 

3. Crash when using the Color Picker tool

This happens when you try to use the Color picker tool more than once from within ProSelect. We are looking for an alternate solution but, in the meantime, in ProSelect 2019r2.4, we have disabled the use of the Color Picker on Catalina and newer to avoid loss of data if you accidentally do this.

4. ProSelect Lightroom Plugin cannot connect to ProSelect

If you get the message "Could not connect to ProSelect. ProSelect may not be running or you may be running an old version (ProSelect 2019r1.7 or newer required)" when trying to export images from Lightroom to ProSelect, follow the instructions in this  KnowledgeBase Article: Lightroom Plugin not working on Catalina  

5. Cannot connect to Photoshop

In October 2020, we came across an issue where ProSelect could not connect to Photoshop when you have external servers connected to Catalina. We discovered that, under these circumstances, OSX was returning the path to Photoshop in a different format from previous versions of OSX which prevented ProSelect from being able to send commands to Photoshop.  A workaround to this issue was added to the ProSelect 2020r1.2 update. 

Reporting any issues

If you are running Catalina or Big Sur and come across any issues, firstly make sure that you are running the latest ProSelect release. You will find a message in the ProSelect Messages window if your version is not the latest one.

If the problem persists then please let us know by submitting a Support Ticket to the ProSelect department. We will keep this page updated with reported issues and when they are resolved. 

 



  KnowledgeBase Article: ProSelect on Mac OSX 10.15 Catalina & newer